Search results

Help Support SportTrac.org:

  1. L

    Alternator Gauge?

    Thanks DILLARD. I have the pre-HEC cluster. Everything returned to normal after I installed the new alternator.
  2. L

    Alternator Gauge?

    Not sure, DILLARD. Busy with other things at the moment - is there a quick way to tell the difference?
  3. L

    Alternator Gauge?

    The alternator in my 2003 failed a few months ago while I was driving. Shortly after failing, as the battery died, the instrument cluster went wonky. Shortly after that, the engine died. Towed it home, replaced the alternator, and it’s been as good as gold since. Replace your alternator. If it...
  4. L

    Probably been posted 100 times at least.

    Since the warranty ended on my 2009 Adrenalin 4.6L 3V engine, I’ve used Mobil 1 synthetic 0W-20. 330,000 km on the truck now and no issues. My industrial lubricant advisor made this recommendation.
  5. L

    2010 Adrenalin

    Hi guys. I have a 2009 Adrenalin with 330,000 Kms, owned since new. I’ve replaced front hubs probably three times on each side. I run slightly larger tires (265/50R20) - might be harder on bearings. I just recently replaced one rear bearing.
  6. L

    Transmission leak

    I had the same problem a few years ago with my 4.6L ‘09 Adrenalin. Dropped the pan, changed the connector (and fluid and filter) and put it back together. All good since. While I was under the truck, I confirmed from stampings on the case that it is a 6R80.
  7. L

    2010 STA 8cy

    No. You plug the cables from the transmission into one side of the connector and the cables from the engine bay into the other side. Very simple. The biggest trick I found was getting the locking ring off the connector plug.
  8. L

    2010 STA 8cy

    Hey Mark, This was several years ago, but the initial problem with the connector was not "the wrench" or limp mode, it was tranny fluid leaking onto my driveway. Eventually though, I believe tranny fluid started leaking into the electrical connector pins, causing it to throw the tranny comm code...
  9. L

    2010 STA 8cy

    I doubt a wheel sensor would put it into limp mode. I’ve had both issues with my ‘09 (failed hub/sensor and the notorious tranny connector). The only time I ever saw the wrench and experienced limp mode was with the tranny connector.
  10. L

    HOW TO LOCK YOUR CAR (Snopes Approved)

    Thanks Rod. Apologies for hijacking this thread :)
  11. L

    HOW TO LOCK YOUR CAR (Snopes Approved)

    Thanks for the suggestion, Rod. Did you find running boards for the Gen2 Adrenalin? I searched the part number (8A2Z-16451-AD) and found nothing. Numerous websites showing it, but all indicate "Discontinued - not available". I only need the driver's side rear tail piece, but I'd consider buying...
  12. L

    HOW TO LOCK YOUR CAR (Snopes Approved)

    Totally sucks. I posted awhile back about a broken tail piece on my STA running board. Not available anymore. Anyone out there with a 3D printer?
  13. L

    New and wondering why I want an STA so bad

    I currently own a 2003 Gen 1 (400,000 km) and a 2009 STA (320,000 km). Both run great, but they do need routine, regular maintenance, no different than any other vehicle. Very happy with both of them.
  14. L

    09' STA Tire Sensor Fault

    I have a "Tire Sensor Fault" up on my display now, and from other posts, it sounds like this may be a dead battery in one of the tire pressure sensors. Does anyone know if these batteries can be replaced, and if so, what battery do they take? I've tried the reset procedure, which did nothing to...
  15. L

    Lugging Noise?

    I pulled the pan to change the leaking electrical connector at the back of the transmission - TSB known issue. With the pan off, I changed the filter and oil (did not do a flush). Len
  16. L

    Adrenalin Running Boards

    Last winter, my 2009 Adrenalin got hit by a large chunk of flying ice from an oncoming vehicle. The ice hit the driver's side running board and broke the back piece off. The body shop is unable to locate a replacement running board (or the back piece) anywhere. Apparently, Ford no longer makes...
  17. L

    Lugging Noise?

    Ian, I have the same thing happening with my 2009 Adrenalin (V8 - 4.6L, 6R80 transmission). I just recently changed the transmission fluid (not to solve this problem) but the sound has not gone away. It doesn't do this all the time---more often on warm/hot days. Will be be grateful if someone...
  18. L

    heated seats

    I had this problem on my '03 several years ago. I took the seat apart and found the heating element wire broken in one spot. Replaced the broke section with heavy gauge wire and soldered it back together. My wife now owns the vehicle and it has not been a problem since. Len
  19. L

    Overdrive Button Malfunction

    Interesting idea, Todd. I'm hoping someone has experienced the same problem and can share what they found before I rip my steering wheel apart.
  20. L

    Overdrive Button Malfunction

    Interesting little puzzle - I have a 2003 ST which I have owned for many years. Recently, the Overdrive button started misbehaving. It works fine if the transmission is in Park, Reverse, or Neutral, but it does not work if the transmission is in a forward gear (Drive, 3, 2, or 1). If I want...
Top