03 Issue with... ?

Help Support SportTrac.org:

Bmathis2511

Member
Joined
Feb 3, 2022
Messages
3
Reaction score
3
Location
Mayfield, KY
Hello All,

I have a 2003 Sport Trac 4.0 4x2 with the 5r55e. I just purchased the truck from a guy who let the thing sit for a year and a half under the presumption that it needed a new ECU.

Previous owner states that when he was driving it. Truck acted normal, then 'suddenly' shut off without warning. Started back up and he 'drove like hell' to get it home, where it supposedly wouldn't start back up.

Fast forward a year and a half later.

I have reinstalled a new battery and installed all the fuses back into the engine fuse box (don't ask me why they removed them all) Hop in the truck, thing starts up fine. Has a little rough idle to be expected. When i put it in drive, goes into gear (at least I think) smoothly. However, transmission will not pull much. Truck will move, only under heavy acceleration. Will also move in Reverse, 1 and 2. If I put into drive and give no gas, truck will stall. Previous owner states that this truck did not show any signs of transmission failure, slipping, or loss of power before this. Anybody know what my issue could be?
 

DILLARD000

Well-Known Member
Joined
Mar 7, 2020
Messages
538
Reaction score
305
Location
Earth
Welcome to the forum.
How many miles on Truck\Engine\Tranny?
As a first try I'd:
~ drop TrannyPan, which drains roughly half of the ATF
~ inspect for blown ValveBodyGasket or loose Solenoids\Wiring
~ reTorq ValveBodyBolts
~ renew TrannyFilter
~ adjust TrannyBands
~ renew TrannyPanGasket
~ refill with fresh MerconV
If that helps, then over the next several weeks
HandPump 1~2qts from the TrannyDipTube & refill with fresh MerconV;
do this several times to get all of the old ATF replaced with new.
If that doesn't help, then likely need a new VBGasket or rebuilt VB or rebuilt Tranny.
I'd also change all of the fluids+filters, considering how long it set.
 

DILLARD000

Well-Known Member
Joined
Mar 7, 2020
Messages
538
Reaction score
305
Location
Earth
Any OBD2 TroubleCodes? If you don't already have one, best to get your own Scanner,
one that reads both StandardSAE & ProprietaryFORD data; can be had for $25~$150.
I've got an OBDLink# MX+ for use with my AndroidPhon & an OBDLink# EX for Windows+ForScan.

If Plugs+Wires (6each) & OxygenSensors (3each) & OilPressurized TimingTensioners (2each)
haven't been changed in last 10yrs\100kMiles, best to get that done.
Won't hurt to run a tank of PremiumFuel & InjectorCleaner thru it also.

You're lucky: 2003 was last year SportTrac had PreHEC Computer+InstrumentCluster;
much easier to troubleshoot\repair\replace than the 2004+Later HEC electronics.

Detailed info on these items & more on my Wiki; click signature link below.
 
Joined
Jan 2, 2014
Messages
41
Reaction score
28
Location
orlando, FL
I don’t go under the truck to drain the transmission fluid anymore…..unless I want to change the transmission filter.
I unscrew the top radiator transmission line cut a piece of garden hose and put it over the transmission line and duck tape it real good so it doesn’t leak out …put the hose in a bucket. …turn car on and let pump out about 4 quarts. It will sputter when none it left.. don’t wait that long
Just 4 quarts then refill 4 quarts do it again
Then one more time till it comes out rosy red. … your done ….complete oil change and you didn’t get dirty or under the car…do that every 30 k
Not the right way….. but real easy
And 10 mins your done.
But you got to change filter every 100k.
 

DILLARD000

Well-Known Member
Joined
Mar 7, 2020
Messages
538
Reaction score
305
Location
Earth
I don’t go under the truck to drain the transmission fluid anymore…..unless I want to change the transmission filter.
I unscrew the top radiator transmission line cut a piece of garden hose and put it over the transmission line and duck tape it real good so it doesn’t leak out …put the hose in a bucket. …turn car on and let pump out about 4 quarts. It will sputter when none it left.. don’t wait that long
Just 4 quarts then refill 4 quarts do it again
Then one more time till it comes out rosy red. … your done ….complete oil change and you didn’t get dirty or under the car…do that every 30 k
Not the right way….. but real easy
And 10 mins your done.
But you got to change filter every 100k.
Similar here with 6mth EngineOil+Filter changes: HandPump 1qt ATF from TrannyDipTube & refill fresh MerconV. Figure this keeps ATF fresh between TrannyPanDrop+Filter changes at 4~5yr\33kMile intervals.
 

Bmathis2511

Member
Joined
Feb 3, 2022
Messages
3
Reaction score
3
Location
Mayfield, KY
Finally checked the codes. Here is what came back
P0446 Evap Control System Vent Check
P0743 Torque Converter CHK Electrical
P0750 Shift Solenoid A Malfunction
P0755 Shift Solenoid B Malfunction
P0760 Shift Solenoid C Malfunction
P0765 Shift Solenoid D Malfunction
P1747 No DTC definition found
P0135 O2S Heater CHK Malfunction
P0140 O2S Heater CHK Malfunction
P0141 O2S Heater CHK Malfunction 1/2
P0155 O2S Heater CHK Malfunction 2/1
EGR Flow CKT Malfunction

With this information, any other ideas before I start tearing this thing apart?
 

DILLARD000

Well-Known Member
Joined
Mar 7, 2020
Messages
538
Reaction score
305
Location
Earth
you def got a lot of crap going on.... Valve body solenoids for sure.... Could be wiring issue too.
I'm also thinking damaged wiring;
pinched\damaged harness to Tranny+OxSensors could cause most of those TroubleCodes?
 
Top