2004 ST project - 181k “K” engine rehab

Help Support SportTrac.org:

GO BILLS Jake

Member
Joined
Jul 31, 2021
Messages
36
Reaction score
40
Location
Coatesville, PA
Third time is a charm! After 23 phone calls, two engines pulled but problems found (no good) and almost 60 days later the used engine arrived. Installing this weekend, save your “K” engines as I’m tearing the old one down this month for rebuild. I ❤️ Ford Blue!!

Before and after pics, I’ve got a great mechanic!!
 

Attachments

  • 4EEA66FD-C4B8-40F1-881A-C928D24AE163.jpeg
    4EEA66FD-C4B8-40F1-881A-C928D24AE163.jpeg
    151.9 KB · Views: 38
  • 3E806EBD-3C2F-4B0A-9E9D-24383CA7486B.jpeg
    3E806EBD-3C2F-4B0A-9E9D-24383CA7486B.jpeg
    163.5 KB · Views: 33

GO BILLS Jake

Member
Joined
Jul 31, 2021
Messages
36
Reaction score
40
Location
Coatesville, PA
OK experts I love the truck, runs nice, blue tooth stereo, road manners are perfect and leather. ONLY ISSUE is it's been back to my engine guy once (and going back again) as after 200 miles rear main seal starts to leak. Replaced under warranty and got back last week. Was dry for 7 days and then BOOM today I have oil spots again in the driveway and coming from between the block and the trans.

Has anyone had two seals go bad in such a short amount of time? Could there be something else? No shimmy, knock, rattles, etc. it runs perfect. This will be the third seal being switched (1 at rebuild out of truck, second when pulled the tranny to access) and now the 3rd.

Any other suggestions I could be missing?
 
Joined
Jan 2, 2014
Messages
39
Reaction score
26
Location
orlando, FL
Got a guy in Spring Hill fla above Tampa that rebuilds 4.0 ohc motors only
And installs. 900 rebuild /1600 install
Had 4 motors r/r in 4 trucks
Great so far
3523406208
On Craigslist
Works out of backyard
Spanish speaking a extra
 
Joined
Sep 29, 2019
Messages
19
Reaction score
6
Location
45459
OK experts I love the truck, runs nice, blue tooth stereo, road manners are perfect and leather. ONLY ISSUE is it's been back to my engine guy once (and going back again) as after 200 miles rear main seal starts to leak. Replaced under warranty and got back last week. Was dry for 7 days and then BOOM today I have oil spots again in the driveway and coming from between the block and the trans.

Has anyone had two seals go bad in such a short amount of time? Could there be something else? No shimmy, knock, rattles, etc. it runs perfect. This will be the third seal being switched (1 at rebuild out of truck, second when pulled the tranny to access) and now the 3rd.

Any other suggestions I could be missing?
The front tensioner can leak and it finds its way through the valley down the back of the block over the tranny bell housing and could mimic a rear main seal. I suppose the rear tensioner could also leak and run down the block and drip near the rear main seal. Also, as Todd Z noted, the PCV connector on the back side of the drivers valve cover could work itself loose and oil could come out that hole on hills.
 
Last edited:
Top