1. Welcome to the new home for MySportTrac.com!

    Please click here to find all the info about the move to the new site!

    To access your account you will need to reset your password here

Banging Noise when Turning Left

Thread in 'Noise, Vibration, Harshness Issues' started by Mark Heisser, May 15, 2020.

  1. Mark Heisser

    Mark Heisser Member 1st Gen Owner V6 Engine

    Messages:
    9
    Likes Received:
    0
    Joined:
    Aug 2, 2014
    Location:
    Fort Worth, TX-
    2001 Explorer Sportrac 175k When making a left turn especially over uneven terrain such as pulling into a driveway I get a loud bang noise from the left rear side, does anyone know what it could be I appreciate it
     
  2. EddieS'04

    EddieS'04 Well-Known Member 1st Gen Owner 2 Wheel Drive V6 Engine

    Messages:
    17,432
    Likes Received:
    143
    Joined:
    Sep 26, 2004
    Location:
    Pasadena, TX
    Check Shock mounts and sway bar end link bushings.
     
    swshawaii likes this.
  3. swshawaii

    swshawaii Well-Known Member 1st Gen Owner 2 Wheel Drive V6 Engine

    Messages:
    5,137
    Likes Received:
    100
    Joined:
    Feb 27, 2009
    Location:
    Kailua-Oahu, Hawaii
  4. Mark Heisser

    Mark Heisser Member 1st Gen Owner V6 Engine

    Messages:
    9
    Likes Received:
    0
    Joined:
    Aug 2, 2014
    Location:
    Fort Worth, TX-
    Ok will take s look tomorrow,replaced the shocks about 30k ago all looked good then
     
  5. Todd Z

    Todd Z Well-Known Member 2nd Gen Owner V6 Engine V8 Engine

    Messages:
    21,184
    Likes Received:
    216
    Joined:
    Sep 21, 2003
    Location:
    Long Island, NY
    Check ball joints and control arms
     
  6. Mark Heisser

    Mark Heisser Member 1st Gen Owner V6 Engine

    Messages:
    9
    Likes Received:
    0
    Joined:
    Aug 2, 2014
    Location:
    Fort Worth, TX-
    It's coming from the left rear did find the sway bar end link bushing wore out but the leaf spring is in the way of pulling it out
     
  7. Todd Z

    Todd Z Well-Known Member 2nd Gen Owner V6 Engine V8 Engine

    Messages:
    21,184
    Likes Received:
    216
    Joined:
    Sep 21, 2003
    Location:
    Long Island, NY
    the leaf spring does not block the sway bar end link.... Sounds like something is broken or bent...
     
    EddieS'04 likes this.

Share This Page