Quantcast

Fuel gauge not working then works after engine restart

Help Support SportTrac.org:

RodMac

Member
1st Gen Owner
V6 Engine
2 Wheel Drive
Joined
Mar 11, 2018
Messages
2
Reaction score
0
Location
Virginia
2005 Sport Trac, I start it and start driving and the fuel gauge reads below empty with no warning light on for low fuel. I pull over and restart the engine and the gauge reads correctly. Any ideas on what is starting to fail? It does not read incorrectly every time I start it.
 

Todd Z

Well-Known Member
2nd Gen Owner
V6 Engine
V8 Engine
Joined
Sep 21, 2003
Messages
21,362
Reaction score
255
Location
Long Island, NY
sounds like the sender is going bad in the tank.... replace the pump too...
 

RodMac

Member
1st Gen Owner
V6 Engine
2 Wheel Drive
Joined
Mar 11, 2018
Messages
2
Reaction score
0
Location
Virginia
I’ll wait for summer to change the sender and fuel pump. Thanks for the direction forward.
 

antny024

Member
Joined
Jan 26, 2021
Messages
24
Reaction score
11
Location
Pompano Beach, Florida
Fuel tank sender/sending unit is probably going bad. Very difficult to diag properly unless you're willing to drop the tank/remove the bed to access the fuel pump.. You would have to remove it and using a multimeter check for proper ohm's when lifting and lowering the float. Usually it's a sign the fuel pump is on it's last leg.. Ford fuel pumps have a tendency to stop working when hot, then starting again when cooled off. Hope that helps.. Good luck
 

WinoOutWest

Member
1st Gen Owner
V6 Engine
4 Wheel Drive
Joined
Mar 16, 2019
Messages
3
Reaction score
1
Location
Kamloops, BC
If you are waiting for spring/summer to pull it you can try adding a few bottles of sea foam to your tank. It seemed to improve (although not totally cure) my gauge flakiness that was doing the same thing.
 

JohnnyB

Well-Known Member
2nd Gen Owner
V8 Engine
Joined
Nov 1, 2000
Messages
998
Reaction score
3
Location
NY
I am having a fuel gauge problem also. It has happened 4 times or so over the last month. The gauge just goes to empty and the low fuel indicator lights up and beeps. After a while it is back to normal the next time i start it. I assume it is what was said above.

Which sea foam product helped?

Thanks
 

Tylerxp2

Member
Joined
Feb 14, 2021
Messages
17
Reaction score
9
Location
Washington state
2005 Sport Trac, I start it and start driving and the fuel gauge reads below empty with no warning light on for low fuel. I pull over and restart the engine and the gauge reads correctly. Any ideas on what is starting to fail? It does not read incorrectly every time I start it.
Mine has done that over the years also. 2004.
After restarting its fine.
I think its a CPU thing, just needs a reboot sometimes. Also maybe check battery voltage. After replacing my battery I haven't had the problem.
Good luck.
 
Top