Need Help for '99 ford escort

Ford SportTrac Forum

Help Support Ford SportTrac Forum:

EddieS'04

Well-Known Member
Joined
Sep 26, 2004
Messages
17,726
Reaction score
268
Location
Pasadena, TX
Im helping a freind on his '99 ford escort. It started stumbling then died, to never start again. There are no codes.

A couple of months ago he had new plugs wires and coil installed. The coil is dis type. All motorcraft parts.

I have checked all sensor conections. All fuses and relays for the ECU/PCU, and injectors are good. The fuel pressure cranks at 40psi and holds 40 psi after cranking. I get a good blue spark on each wire while cranking. The MAF and ATC are clean. I have held the throttle open during cranking, as to bypass the IAC. It just wont start. I thought about the crank sensor, but I understand they work or not.

It has 90k miles on it. never had a timing belt change. I have wondered if that has jumped time. This is the 2.0L ohc motor. I dont know if it is a non interference motor. I told my buddy if it is an interference motor the valves will cratter the pistons. If that is the problem and the belt jumps again. I havent pulled the belt covers to check timing alighnment

The motor cranks at normal speed. Any Ideas or anyone had something simular happen. Im good at trouble shooting and understand sensor issues, but Im stumped.:banghead:

I was hoping to save him some $$ as he lives on disability from HPD.

Thanks for any Ideas', Eddie
 

Todd Z

Well-Known Member
4 wheel drive
2nd Gen owner
V8 Engine
Joined
Sep 21, 2003
Messages
22,123
Reaction score
625
Location
Long Island, NY
I believe the top cover is easily removed, Check the time.....



If not I had one let a head gasket go did the same thing. did you ohm the injectors ??



did you spray fuel in the intake??



Just doing the basics..



Todd Z
 

EddieS'04

Well-Known Member
Joined
Sep 26, 2004
Messages
17,726
Reaction score
268
Location
Pasadena, TX
Thanks Todd,

I will get some starting fluid. Or maybe some fuel in a squirt bottle. If it starts, I will check the injectors.

His air filter was way past replacing. IDK if the fuel filter is the same. It might have ruptured and pluged the injectors.

He doesnt have the mechanical inclination we do.
 

Tom Schindler

Well-Known Member
1st Gen Owner
V6 Engine
Joined
May 30, 2002
Messages
13,973
Reaction score
2
Location
Akron, OH
First I would check the hose from the MAF to Intake Plenum. Second, I would check compression.





Tom
 

Duane Foster

Active Member
Joined
Jan 1, 2013
Messages
348
Reaction score
22
Location
Des Moines, IA
http://www.feoa.net/



You might try posting on the site above which is the Ford Escort Owners Assn. I've posted questions relating to our '98 Escort and received answers pretty quickly. Those guys seem to know their Escorts very well.
 

Latest posts

Top