Windshield Wiper Arm not moving

Help Support SportTrac.org:

Jim Nicholson

Member
1st Gen Owner
V6 Engine
Joined
Jun 2, 2003
Messages
19
Reaction score
0
Location
Salem, NH
Hello All,



Sorry if this has been asked already. I tried searching to no avail. I have a 2003 Trac..still going strong. Recently the passenger side wiper stopped moving. I can move it free hand but the motor will not power it. Anyone know where to start looking at this and whether or not this is an easy fix?



Love my Trac...I just recently replaced the original factory battery!!



thank you,

Jim
 

Todd Z

Well-Known Member
2nd Gen Owner
V6 Engine
V8 Engine
Joined
Sep 21, 2003
Messages
21,445
Reaction score
316
Location
Long Island, NY
It is easy to fix.



Remove the arms, Take out center screw, Remove black plastic trim under arms, and you will see the whole transmission. See what part broke, And replace.



The way to remove the

plastics is a project in the projects section on removing them for a wiper drain.



Todd Z
 

Dean Hedin

Active Member
1st Gen Owner
V6 Engine
Joined
Nov 30, 2002
Messages
248
Reaction score
0
Location
Hatboro, PA
One of my wipers stopped moving on my 2003 about two years ago.



It turned out to be that one of the little ball joints failed that connects the crank from the motor to the crank on the arm. The socket part of the ball joint is a plastic insert that is press fit into each end of the connection bar that goes from the motor crank to the wiper arms cranks.



The ball rusted a little and then started to eat the plastic cup out. I don't think it was greased very well from the factory. I cleaned up the ball and machined a new socket insert out of nylon on my lathe. Greased it, then pressed the ball into it with the bench vice.



It's been fine ever since. Maybe you can get the part from Ford, but you might be better off scouting the bone yards for a replacement arm with the inserts. Otherwise you need a lathe, nylon, and the relevant skills.



Good Luck.
 

Jim Nicholson

Member
1st Gen Owner
V6 Engine
Joined
Jun 2, 2003
Messages
19
Reaction score
0
Location
Salem, NH
Thanks guys. It turns out the arm just got separated. I popped it back on. We'll see how long it goes and see if it happens again then I'll replace it. This happened last week while my Sister in law had the truck and I was in Florida and there was a bad ice storm here in NH. Dollars to donuts I would bet she was too lazy to scrape the damn windshield and turn the wipers on....
 

Jim Nicholson

Member
1st Gen Owner
V6 Engine
Joined
Jun 2, 2003
Messages
19
Reaction score
0
Location
Salem, NH
On a side note....They certainly do not give you much slack on the washer hose. Man it was tough getting the passenger side reconnected with such little slack.
 

Latest posts

Top