Quantcast

07 Sport Trac Sub Woofer Amplifier Drains the battery

Help Support SportTrac.org:

Joined
Aug 17, 2017
Messages
1
Reaction score
0
Location
MANNING, SC
Does anyone know a fix to the problem we have, of the Sub woofer amplifier draining the battery over night? Yes the radio is off when we turn the key/truck off. We pull fuse number 22 (sub woofer/satellite radio), and the problem goes away (but the sound system is equal to a KIA now... Anyone encountered this problem? and... what caused it???
 

Todd Z

Well-Known Member
2nd Gen Owner
V6 Engine
V8 Engine
Joined
Sep 21, 2003
Messages
21,365
Reaction score
260
Location
Long Island, NY
It sounds like the third brake light was leaking and shorted out the amp, or got it wet.....



Look behind the panel and under the sub for water when it rains......



May be able to just take the amp out and apart and clean it if all corroded or replace.



If not have to start testing the amp and sat radio module for drains.



Todd Z
 

philipac

Member
Joined
Feb 19, 2021
Messages
1
Reaction score
0
Location
south carolina
i have this same problem in my 04 but as of now i just unplug the amp every time i leave it, or when i remember anyway.
 

EddieS'04

Well-Known Member
1st Gen Owner
V6 Engine
2 Wheel Drive
Joined
Sep 26, 2004
Messages
17,511
Reaction score
170
Location
Pasadena, TX
After doing the checks that Todd Z recomends. If it persists My thought are to splice into the power wire on the amp. Run it back to a switch on the dash that seen, as to turn it off. tap the fuse box out wire with a switch that would be closer and less wire.
 

Latest posts

Top