Cruise control issue

Ford SportTrac Forum

Help Support Ford SportTrac Forum:

Guswah

Member
Joined
Nov 28, 2021
Messages
53
Reaction score
18
Location
Canada
I've had my 2005 SportTrac for about a year now. The cruise worked well, but the buttons did seem weird -- hard to push, hard to find the contact spot when you push. I'm sure readers know what I mean.

Yesterday I suddenly had no cruise at all.

Is there a remedy that occurs to someone who might have had the same problem? Is there a replacement part that might restore my cruise to its original magic? Just throwing it out there. I do like my CC!
 
Joined
Nov 28, 2016
Messages
22
Reaction score
8
Location
Burke, VA
I had my cruise control go away on my 2010. I reset the ECM my disconnecting and reconnecting the cables. Disconnected the battery first. CC came back but, months later had all sorts of errant codes. Mechanic(should have handled out myself) sent computer off for repairs (twice) still have on code and now no cruise control. I took it back from the mechanic because he had my truck so long it cost me more than the repairs themselves. I’ll be addressing it myself or go to dealer after I finishing regaining the wealth I lost in this lesson
 

Double Down

2008 White Suede Limited V8
2 wheel drive
2nd Gen owner
V8 Engine
Joined
Jan 24, 2009
Messages
10
Reaction score
4
Location
Riverside, CA
I had my cruise control go away on my 2010. I reset the ECM my disconnecting and reconnecting the cables. Disconnected the battery first. CC came back but, months later had all sorts of errant codes. Mechanic(should have handled out myself) sent computer off for repairs (twice) still have on code and now no cruise control. I took it back from the mechanic because he had my truck so long it cost me more than the repairs themselves. I’ll be addressing it myself or go to dealer after I finishing regaining the wealth I lost in this lesson
Had cruise control go out on my 2008, was intermittent, then horn and sync quit. Turned out changing the clockspring fixed it. $120 part from dealer, took about an hour at home, including the 30 minute wait after disconnecting the battery to make sure the airbag had no power.
Might or might not be same fix for your issue, I didn't have error codes come up at that time.
 

EricP

Member
V6 Engine
2 wheel drive
2002 1st Gen
Joined
Jun 25, 2019
Messages
25
Reaction score
18
Location
Veneta, OR
Many years ago I had a scary situation with my cruise control, and haven't trusted it since. I was on a hilly, but straight, highway when the CC accelerated for one of the hills. It kept accelerating after I reached the top of the hill. Hitting the brake pedal made it accelerate faster. I couldn't turn it off, either. I finally had to turn off the engine and coast to the side if the road. Upon inspection, I found that the CC cable was jammed (I forget the exact details). I cleared it and went on my way. No more problems with it until about 45 minutes later on a different highway, and it did it again. I was prepared this time and didn't waste any time trying to clear it while driving. I haven't used it since, and don't miss it. Never did figure out what caused this to happen.
 

Guswah

Member
Joined
Nov 28, 2021
Messages
53
Reaction score
18
Location
Canada
Many years ago I had a scary situation with my cruise control, and haven't trusted it since. I was on a hilly, but straight, highway when the CC accelerated for one of the hills. It kept accelerating after I reached the top of the hill. Hitting the brake pedal made it accelerate faster. I couldn't turn it off, either. I finally had to turn off the engine and coast to the side if the road. Upon inspection, I found that the CC cable was jammed (I forget the exact details). I cleared it and went on my way. No more problems with it until about 45 minutes later on a different highway, and it did it again. I was prepared this time and didn't waste any time trying to clear it while driving. I haven't used it since, and don't miss it. Never did figure out what caused this to happen.
What year was your SportTrac?
 

Phil Frady

Active Member
Joined
Mar 14, 2002
Messages
188
Reaction score
43
Location
Douglasville, GA
I've had my 2005 SportTrac for about a year now. The cruise worked well, but the buttons did seem weird -- hard to push, hard to find the contact spot when you push. I'm sure readers know what I mean.

Yesterday I suddenly had no cruise at all.

Is there a remedy that occurs to someone who might have had the same problem? Is there a replacement part that might restore my cruise to its original magic? Just throwing it out there. I do like my CC!
You can order new buttons from the web and it is easy to replace.
 
Top